Hanlin v3: “Invalidate File. Please Check Your Update File”

Si tienes un libro electrónico Hanlin v3 e intentas actualizar su firmware es posible que te encuentres con el mensaje Invalidate File. Please Check Your Update File.

Asegúrate de que el archivo está bien descargado, que el archivo descomprimido V3update.bin se encuentra en la raíz de la SD, que la tarjeta SD tiene un tamaño menor de 1GB y que está formateada como FAT16. Si sigue sin funcionar, puedes probar a formatear la tarjeta utilizando el programa Panasonic SD card formatter.

Comentarios
  1. Hablando del Hanlin… cual es el sitio más economico para pillarlo ahora mismo?? Los vi por 300-350€ y me echó para atrás.

    Responder

  2. En España lo puedes comprar por 299€ a Apollo XXI, que los importa a Jinke (el fabricante) o a Gramatta, que vende un Hanlin v3 cambiado de nombre (Papyre 6.1) y que está en promoción rebajado de los 350€ a los que suelen venderlo.

    Si no te importa comprárselo a Jinke directamente (la sede está en china) lo venden por 300$ (unos 200€).

    Responder

  3. Creo que ya miré la opción de Jinke, pero creo recordar qe los gastos eran 50-60€ 🙁 (y por tan poca difernecia…)

    Esperaré a ver si bajan de precio en España ^_^

    Responder

  4. Nexus

    Estoy pensando comprar uno, pero con lo que valen me estoy tratando de informar mucho, y tengo una duda:

    He leido que el V3 es un poco incomodo en el aspecto de tener que ir bajando por la pagina puesto que no cabe entera en la pantalla; algo que no pasa con el V9 porque tiene la pantalla es más grande. Entonces tengo una duda: ¿qué es mejor portabilidad o comodida?

    Es decir, un V9 tienes la página entera, pero claro, es más grande y ya no estanto “tamaño libro” Los que lo habeis probado ¿es tanta esa incomodidad de tener que bajar la página?

    Es que además la diferencia de precio entre uno y otro modelos no es dos eurillos…. :-/

    Gracias por adelantado!

    Responder

  5. @Nexus el hanlin v9 todavía no está en el mercado, y no se sabe la fecha en la que saldrá.

    Si utilizas archivos PDF, y no quieres o no puedes convertirlos, si puedes tener algún problema. PDF es un formato pensado para imprimir, no para leer, y mucho menos para leerlo en un tamaño de pantalla para el que no estaba pensado. ¿Por qué? Pues porque no es nada sencillo hacer reflow del texto.

    ¿Y esto qué significa? Te explico con un ejemplo.

    Imagina que tienes una línea de texto cualquiera, como “me voy a comprar un libro electrónico, también llamado lector de tinta electrónica”. En una pantalla de 10” puede que quepa la línea entera. En una más pequeña, la mejor solución sería cortar el texto en dos líneas, y esto es lo que ocurriría si tienes un libro en formato txt, rtf, fb2, … pero con un PDF no es tan sencillo, así que lo que hace el Hanlin es hacer zoom, y mostrar sólo media página, o mostrarlo en apaisado para tener más espacio.

    Como un Hanlin v9 tiene un tamaño de pantalla mayor, se verá más grande. Pero esto no quiere decir que no puedas leer archivos PDF en el Hanlin v3, es solo que es más cómodo convertirlos a otro formato como FB2, en el que podrás leerlo con el tamaño de letra que quieras, el interlineado que quieras, el tipo de letra que quieras, …

    Para hacerte una idea echa un vistazo a mi review del Hanlin v3, con la que puedes hacerte una idea de cómo se vería un PDF sin tocar.

    Responder

  6. Nexus

    Conocía tus posts sonbre el V3 (de hecho es POR CULPA TUYA que seguramente crearé un agujero en mi economía ;-).

    Sí entiendo eso del pdf y la necesidad de convertirlo a otros formatos, pero me refería más a qué es mejor, pantalla más grande (aunque menos “portable”) o pantalla pequeña (con la necesidad de ir pasando de paginas con más frecuencia) Quizá no debí nombrar el V9. SOlamente es eso, si en el futuro me convendría buscar un ebook con pantalla que equipare cada pagian del libro ono es para tanto.

    Por cierto, deduzco que tu ebook te entusiasma, porque MENUDA REVIEW que le hiciste! Eso es detalle y lo demás son cuentos…

    Responder

  7. @Nexus, mi impresión después de 24h de tener el Hanlin en mis manos:

    Como tu, me leí la review, tanto de la comparativa entre lectores de e-books como la del propio Hanlin. Entre otras cosas, Zootropo, eres culpable de que me haya comprado el susodicho gadget 😉

    Bueno, al grano. El caso es que tengo un montón de documentos en formato pdf (libros diversos y manuales). Mi intención era visualizarlos en el Hanlin. Aquí mi primer chasco. Muchos documentos se visualizan con un tamaño de fuente muy pequeño pero se pueden leer tranquilamente si se aplica el zoom. Aun así, el texto queda pequeño y es un poco molesto.

    Respecto al formato bf2, en mi Hanlin tarda en cargarlo 23s y para ampliar el texto, unos 12s más. Me parece excesivo pero al ser operaciones que solo se hacen una vez por documento, se puede permitir la espera.
    Lo que ya no me gusta tanto es el tema de la conversión de pdf a bf2. Si piensas que BookDesigner (el converter de facto) es una herramienta K.I.S.S. como yo pensava -iluso de mi- estas muy equivocado. Resulta ser un conversor pdf -> texto temporal -> bf2, de conversión no limpia. Uno mismo tiene que formatear el documento intermedio: espaciar, meter metadata, los links incrustados del pdf se rompen, los indices se joden… (probado con el pdf: GNU Emacs manual). Además, el simple de echo de tener innumerables opciones que configurar ya echa pa tras. Yo quiero algo limpio y rápido y no tener que aprender un programa solo para poder visualizar correctamente mis manuales (por cierto, el look&feel del BD asusta de cojones!).
    Así que descarta la conversión rápida pdf -> bf2.

    Volviendo al formato pdf. En tan solo 24h he encontrado dos bugs al renderizar o cargar el pdf. Uno es al darle zoom. A veces, el aparato se come parte del margen derecho con lo que el final de cada linea se corta. Esto se soluciona volviendo al estado original de la página (sin zoom) y darle otra vez zoom (como un cíclo). Misteriosamente, después de este proceso mágico el texto de la página se visualiza bien (solo de la página actual. El error puede volver a ocurrir en páginas posteriores solventándose de la misma manera).
    El otro bug, más preocupante, es que ciertos documentos pdf no los puedo visualizar. Por ejemplo, una de las razones para comprarme el Hanlin fue para leerme el libro C++ GUI Programming with Qt 4 (http://digg.com/programming/Free_e_book_C_GUI_Programming_with_Qt_4_Zip_with_PDF) y no tener que imprimir o en su defecto, comprarme el tocho. Parece ser que al Hanlin no le sienta bien y no lo carga; bueno, lo carga pero vuelve al menú para seleccionar un nuevo documento (raro eeehhh).

    Todo esto lo achaco a errores en el parser del pdf del firmware. Aquí mi indignación cuando voy a bajarme el firmware y actualizar de la versión de la V1.23 a la V1.27. En la página web oficial resulta que el firmware no esta o no lo se encontrar. Tal vez es que soy un zoquete, pero mira que he estado mirando y no hay manera:
    Jinker -> Update -> V3update hanlin V1.27 (Download) -> Download Name: V3 update package -> V3update hanlin V1.27 (Download) -> Download Name: V3 update package -> V3update hanlin V1.27 (Download) -> Download Name: V3 update package -> … (stack overflow!!!)

    En resumen: La cosa ha ido decreciendo durante el día, pasando de la expectación, conformismo, un poco de decepción y finalmente, un pequeño cabreo.
    Obviamente esta es mi primera impresión, carente de cualquier rigor y que de bien seguro cambiará ,espero que a mejor, a lo largo de estos próximos días.

    Saludos

    PD: Zootropo, desde tu post de los lectores de ebooks que te agregué en mi selecto grupo de feeds. Sigue así.

    Responder

  8. ¡¡Eres el mejor!!

    Pensaba que no me actualizaba por problemas en la versión de Julio del 2008, me mosquee al ver que tampoco cargaba la de Septiembre con ninguna tarjeta dándome el error “Invalidate File. Please Check Your Update File”, probé formatear una de mis tarjetas con la aplicación de Panasonic y me ha cogido el fichero sin problema y me lo ha actualizado.

    ¡¡Ahora a probarlo con el Mobipocket!!

    Responder

  9. Para eso estamos, Andromeda 😉

    Responder

  10. Petro

    Zootropo, que tal, excelente pagina.
    Me interasaría este aparato por la posibilidad de mejores actualizaciones, por estar basado en sistema operativo Linux. Pero me interesaría para leer documentos en pdf o chm muy grandes, en promedio de 20 – 30 MB, llegando a los 100 MB o más en algunos casos, los cuales incluyen imagenes, mi duda es que tal se ven estos documentos en el lector, y que tanta alteracion hay en caso de cambiar el formato del archivo, o si sería mejor intentar con un Sony Digital Reader. Gracias por la información. Saludos

    Responder

  11. PDF en realidad no está pensado como un formato para leer, sino para imprimir, lo que hace que no se pueda ajustar el documento a tamaños de pantalla más pequeños que el tamaño para el que fueron creados.

    Como casi todos los PDF se crean para un tamaño de hoja A4 o similar, si quieres ver el texto perfectamente, lo único que puedes hacer es comprar un lector de tinta electrónica que tenga un tamaño de pantalla cercano a un A4, es decir, un iRex iLiad. Pero claro, es bastante más caro.

    En un Hanlin v3 puedes leer PDFs, pero el tamaño de letra y de las imágenes será más pequeño.

    Siempre puedes convertir el PDF a otro formato, como doc o fb2, con los que no tendrás ningún problema, pero si el formato del archivo es complicado puede que el resultado que devuelva el programa que utilices para convertirlo no sea el esperado.

    Conclusión: si lees muchos libros técnicos compra un iLiad, si por el contrario sueles leer novelas o cualquier otro tipo de libro en el que no sea muy importante el formato, un Hanlin es una gran compra.

    Responder

  12. Danri

    Seguimos en la tónica de actualizar el firmware del Hanlin a peor. Digo esto porque en menos de diez minutos he vuelto a la versión 1.26
    La versión 2.00 según dicen soporta mobipocket pero ¿para que quiero nuevos formatos si estropean los que ya teníamos?
    Desde que compré el lector me pasé a la versión 1.26 que sí lee archivos fb2 de más de 2Mb, ejemplo: Los Pilares de la Tierra: 2,56 Mb.
    Pero cual fue mi sorpresa y susto al ver que al disponer de la nueva versión 2.0 e intentar abrir el ebook de Follet, se me reinicia el Hanlin. Le hago un soft reset (botón en la parte de atrás) pero nada, cada vez que intento abrir el libro se reinicia.
    He probado con otro libro más light 2,23Mb, idem de lo mismo.
    Así que vuelta al firmware anterior que me lo abre sin problemas.

    Responder

  13. Yo no he tenido ningún problema similar Danri.

    Responder

  14. Danri

    Hola a todos y gracias a Zootropo por tu contestación.
    La cuestión es que los libros están en formato fb2 y ha sido lo que más me ha extrañado.
    He podido observar que jinke tiene el firmware 2.0 en su página web pero tanto papyre como lbook tienen aun la versión 1.27 como la última.
    Mi pregunta es ¿Por qué es jinke la única que tiene esta versión y los demás tienen la anterior?
    Me imagino que los demás se basan en jinke pero no lo entiendo.
    Hay otra cuestión que la verdad me tiene un poco intrigado y es que en la mayoría de los foros todo el mundo quiere que el Hanlin, Apollo, lbook, papyre, etc (distintos nombres pero mismo lector)… tengan compatibilidad con el Mobipoket, pero es que los libros salen más elaborados y mejor presentados en fb2 con la ayuda del BookDesigner.
    Y por último, pero no por ello menos importante es darte las gracias Zootropo por haberme aconsejado tan sabiamente que me compre y no pueda dejar de lado el leer con el Hanlin, desde luego todo lo que sé, desde donde comprarlo hasta como usar el BookDesigner, actualizar el lector, etc… te lo debo a tí.

    Responder

  15. Kiermel

    Danri.
    Tienen aún la 1.27 porque es más estable, y la 2 no lo es aún. Yo me guío por los del papyre para actualizar.
    Los del papyre (grammata) han sacado un conversor muy cómodo de usar. En la wen de lectoreselectronicos.com hay un post de ellos con el enlace de descarga.

    Responder

  16. Danri

    Kiermel
    Gracias por los comentarios, sigo con la versión 1.27 de lbook porque como comentas la 1.27 es más estable.
    He probado el GConversor v1.2 y más fácil imposible aunque para mí que lo haga todo el ordenador me resulta poco atractivo, con el BookDesigner tardo más, pero me deja tener control sobre el diseño del libro, gracias de todas formas por comentarme lo del conversor.
    Creo que si el formato fb2 es uno de los mejores formatos para leer en el Hanlin (y demás nombres), no sería mala idea que sacarán un programa algo más intuitivo que el BookDesigner pero no por ello menos potente. Teniendo en cuenta que la última actualización del BookDesigner es del 20 de julio de 2007.
    Otra cosa que me gustaría es que si anda por ahí algún programador que pudiera hacer un emulador del e-book para el ordenador, creo que para alguien con experiencia no tendría que ser muy difícil, tanto para PC como para Mac, ¿verdad Kiermel?.
    Un saludo a todos y gracias por vuestras opiniones puesto que son de gran ayuda.

    Responder

  17. Cualquiera

    Tengo ese problema. ¿A alguien le ha funcionado con una tarjeta de más de 1Gb (yo tengo de 2Gb) creando una partición de menos de 1Gb?

    Responder

  18. Rosaber

    Me descargo el archivo V3update.bin y aparece con logo de vídeo (Videolan) pero no se ve nada. Lo que no sé es como se puede descomprimir eso. Lo paso a la SD, la pongp en el Papyre y me da el error Please Check Your Update File.
    la tarjeta es de 2 G y era nueva recién comprada por lo que no la formateé.
    El asunto es que mi Papyre no me lee los epub porque si no, para nada lo actualizaba.
    ¿Qué puedo hacer?

    Responder

Deja un comentario