“The Composite extension is not available” en Ubuntu, con ATI

Si os encontráis con el mensaje “The Composite extension is not available” al intentar activar los efectos visuales (Compiz Fusion) en Sistema -> Preferencias -> Apariencia, Efectos visuales en Ubuntu Gutsy Gibbon usando ATI es posible que podáis solucionarlo simplemente instalando el paquete xserver-xgl.

En esta versión de Ubuntu no es necesario nada más. Ni crear una nueva sesión que inicie con XGL ni similares. Simplemente ejecutad el comando

sudo aptitude install xserver-xgl

reiniciad, y a disfrutar 🙂

55 pensamientos en ““The Composite extension is not available” en Ubuntu, con ATI”

  1. Y con suerte, esta semana saldrá el driver 8.42 de ati que permitirá usar AIXGL, por lo que podremos olvidarnos de XLG de una vez por todas.

    Tener buen rendimiento 3d y Compiz con ATI es un sueño que pronto se nos hará realidad 😀

  2. Qué gozada la nueva versión de Ubuntu, la verdad que me esperaba más bien otra cosa, pero como no, los de canonical no me han defraudado.

    Muchas gracias por comentar lo de server-xgl.

    Saludos !

  3. Del tiempo que llevo probando Gutsy (Tribe 1) nuna he logrado levantar establemente Compiz Fusion con mi ATI 9550 256mb, corre por un tiempo pero rapidamente se cae??? te pasa a ti??

    Sobre lo del AIGLX para las ati algo e escuchado… este nuevo driver 8.42.4 soportará todas las tarjetas de ATI o será como el 8.41 que es solo para algunas tarjetas??? alguien sabe algo???

  4. Lo que yo no entiendo es como no han hecho un asistente para instalar XGL o por lo menos un mensaje de advertencia diciéndote que tienes que instalar ese paquete (como ocurre con los codecs). Yo ya lo deduje la primera vez que me ocurrió, pero es posible que a cualquier otra persona no se le hubiese ocurrido tan fácilmente.

    Por otra parte hay que tener en cuenta la sangrante cantidad de bugs con las que cuenta esta versión “estable” de Gutsy Gibbon. Sobre todo en el ámbito de los dispositivos de almacenamiento externo (que pasado un tiempo se me desconectan solos, sin tener idea de por qué) y en el manejo de los efectos y plugins de Compiz.

    A ver si en una semana arreglan muchos de los pequeños grandes fallos que ya empiezan a pesarles a muchos (y a mí mismo).

  5. Yo creo que no han activado un asistente para XGL porque confian en que los drivers de ATI se publiquen en esta semana y de esa forma al activar los drivers propietarios de ATI ya estarán disponibles los 8.42 con soporte para AIXGL.

    El driver 8.42 servirá para todas, no solo para algunas de las más nuevas.

  6. Muchas gracias por la informacion, yo soy nuevo en esto de ubuntu y me sorprendio que no funcionaran los efectos de escritorio, pero hice ese sencillo paso y ahora los tengo disponibles. Es lo malo de la incompatibilidad del hardware con ubuntu.

  7. Pingback: Blog de l’Aniol » 7.10…

  8. Sistema -> Administración -> Origenes del software.

    En descargar desde selecciona “Otro” y ahí pulsa “Seleccionar el mejor servidor”.

    Se pondrá a hacer pruebas de latencia y similares y generará el nuevo sources.list con los mirrors que te vayan mejor.

    Supongo que algún mirror te tirará.

  9. He instalado el xgl-server y me da el aviso de que cuando habra una nueva sesion se iniciara solo.

    Pero eso lleva poniendolo tras 4 reinicios y varios inicios de sesión…

    ¿alguna forma de forzarlo?

  10. Pingback: Imprescindibles para Ubuntu con un sólo clic

  11. Pingback: fglrx 8.42.3: Compiz Fusion con ATI y AIGLX

  12. Muchas gracias! llevaba mucho tiempo intentando poner compiz y nada … la aceleracion grafica la tenia y instalaba paquetes pero como si no… luego me salia ese maldito mensaje siempre y ahora solo instalar ese paquetito y todo de maravilla 😀 un placer me apunto tu blog!

    Gracias

  13. Hola! recien instale gutsy, y luego de tener un ultimate fighting con la pc logre que aceptara el driver de ati. Luego que instalo en xgl, la pc se pone LENTA! yo tengo una ATI 9550 y 1 Gb de ram en un P4…

  14. Acabo de instalar Gutsy y a lo primero que fui fue a habilitar los efectos…para mi sorpresa, el mensaje que me dió fue el que se trata en este post, espero que con la recomendacion me funcione, ahora toy instalando el amsn, y espero pronto poder aprovechar los efectos del escritorio, aunque tenga una ATI X-300
    Muchas Gracias desde YA!

  15. Pingback: enGeneral » Blog Archive » Error en Ubuntu “The Composite extension is not available”

  16. Un tema importante es que, después de activar los drivers propietarios, y antes de ponerse a activar los efectos 3d y todo eso, sería conveniente comprobar si tenemos el rendering activado.

    Se hace con este comando:
    glxinfo | grep rendering

    Si dice ‘Yes’, entonces ya sólo queda, tal como nos ha indicado zootropo, instalar xgl y ya todo va como la seda.

    Yo he tenido que reinstalar Ubuntu al pasarme a Gutsy Gibbon, pero una vez hecho eso todo ha ido estupendo. (Había ya tocado muchas opciones y no había manera, y además, como tengo en particiones distintas home y /, reinstalar es cosa de niños).

    Muchas gracias Zootropo, gracias a ti hoy tengo 3d. Ya veremos qué pasa al tener el nuevo driver, si tenemos que quitar xgl 🙂

  17. Edit: Una vez activado xgl y todas las opciones vistosas 3d, el comando glxinfo | grep rendering me dice que no tengo rendering activo.

    Os lo digo por si os pasa que no os preocupéis, imagino que será debido a que como xgl es otra capa encima de todas las demás, igual con glxinfo no se vé, pero la aceleración está ahí.

  18. Perdón por el spam.

    Zootropo, si me da problemas, intentaré quitar xgl, y si me sigue dando problemas, tardo menos 10 en reinstalar, ya te digo que tener las particiones hechas lo hace todo muy fácil 🙂

    Muchas gracias una vez más.

  19. Tengo una computadora con una tarjeta de video ATI Radeon Xpress 200 a 256 y los gráficos no me corren… ¿será por mi tarjeta o a qué se deberá?

  20. Pingback: e-Zine InSecurity» Blog Archive » Solucionar problemas ATI - Compiz-Fusion Ubuntu 7.10

  21. tengo un amd 64×2 con una ati radeon x1150 y tengo dramas a xq instalo linux ubuntu y ya despues quiero instalar la ati pero no me deja no cacho xq e intentado varias cosas pero no me funciona espero que me puedan ayudar
    vale
    gracias

  22. A mi me da el mismo problema pero como no tengo internet lo descargue desde archive.ubuntu.com pero al tratar de instalarlo el archivador para abrir los .deb me da un error libglitz-glx1 y no se de donde descargarlo

  23. Buenas,

    Yo sigo teniendo el problema. Si instalo el paquete xserver-xgl, al reiniciar no es capaz de iniciar sesion, se queda el color de fondo y al rato vuelve a la pantalla de login.

    Si desinstalo el xserver-xgl ya inicia sesion bien… alguna solucion please?

  24. Hola gente. Veo que la mayoría utiliza tarjetas ATI… Y a los que tenemos una nVidia… ¿¿¿???. Más específicamente: nVidia GeForce 8400 GS 256mb… La cosa es que cuando terminé de instalar Gutsy, me salio un mensaje que mencionaba algo sobre utilizar “Restricted Drivers”, o por lo que entendí, drivers que son propietarios de un hardware específico, y que los c@8r0n35 de los fabricantes no comparten sus fuentes para que la comunidad pueda trabajar con este hardware y poder meterle mano a los drivers, para adecuarlo al O.S. — Les cuento todo esto, porque aunque se supone que ya tengo activada la parte de efectos de Ubuntu, nunca habia visto mi máquina tan lenta… Y la máquina es un Intel Core2 Duo de 2.2Ghz, con 2Gb en Ram, disco de 160Gb SATA2 y la tarjeta de video que mencioné al inicio… Consulté en la página de nVidia, y el driver disponible es el mismo que ya está instalado actualmente. Entonces.. que puedo hacer? que me falta hacer? o que debería hacer? para que la parte gráfica funcione como debe. Un saludo pa’ todos desde Costa Rica. AlexC2.

  25. Hola gente. Veo que la mayoría utiliza tarjetas ATI… Y a los que tenemos una nVidia… ¿¿¿???. Más específicamente: nVidia GeForce 8400 GS 256mb… La cosa es que cuando terminé de instalar Gutsy, me salio un mensaje que mencionaba algo sobre utilizar “Restricted Drivers”, o por lo que entendí, drivers que son propietarios de un hardware específico, y que los c@8r0n35 de los fabricantes no comparten sus fuentes para que la comunidad pueda trabajar con este hardware y poder meterle mano a los drivers, para adecuarlo al O.S. — Les cuento todo esto, porque aunque se supone que ya tengo activada la parte de efectos de Ubuntu, nunca habia visto mi máquina tan lenta… Y la máquina es un Intel Core2 Duo de 2.2Ghz, con 2Gb en Ram, disco de 160Gb SATA2 y la tarjeta de video que mencioné al inicio… Consulté en la página de nVidia, y el driver disponible es el mismo que ya está instalado actualmente. Entonces.. que puedo hacer? que me falta hacer? o que debería hacer? para que la parte gráfica funcione como debe. Por cierto, no sé si esta bien que deje este mensaje aqui… (Ya saben, uno que apenas está comenzando con Linux y esto de dejar mensajes en foros… :o) Un saludo pa’ todos desde Costa Rica. AlexC2.

  26. Pingback: El Francotirador » Cómo instalar Compiz con Ubuntu en un portátil con tarjeta ATI

  27. A mi me pasa lo mismo que al amigo Ivy, cuando instalo el paquete xserver-xgl y reinicio, pongo usuario y contraseña y no me deja entrar siempre vuelve a la pagina de login; entro en modo prueba de fallos lo desinstalo y todo vuelve a la normalidad si alguien sabe algo por aqui estamos un saludo y gracias.

  28. Pingback: Personalizando tu ubuntu « Akuariux’s Weblog

  29. hola, yo tengo instalado ubuntu 7.10, he instalado el ultimo driver de ati, pero tengo un pequeño problema, y es que el raton me va ralentizado. ¿alguien sabe porque puede ser? un saludo

  30. Yo recien estoy entrando a lo que es linux y estoy comenzando con ubuntu 7.10 y como muchos he tenido problemas por lo de la tarjeta ati radeon. La mia es radeon xpress 1100. El caso es que no lograba lo de la aceleracion y con este tuto pude lograrlo. Claro, estoy aqui porque me mandaba ese mensajito de “The Composite extension is not available”

  31. Hola, para nuestros amigos: IVI y PODOCARPUS, a mi me pasaba igual, lo que pasa con esto es que si has istalado el dirver que ofrece ATI siguiendo los pasos del WIKI, por supuesto que te dara este error, lo que tienes que hacer es Instalar el Driver Privativo que trae Ubuntu y luego hacer lo que te dice nuestro amigo:

    sudo aptitude install xserver-xgl

    y luego cambiar de usuario, le das a OPCIONES y eliges la OPCION 1:

    1. Ejecutar Script Xclient

    y listo. a mi me funciono de mil maravillas. suerte

  32. Pingback: Imprescindibles para Ubuntu con un sólo clic | BLOG AMICSMANIA

  33. Pingback: macuoren » Blog Archive » Instalar y Configurar Ubuntu en iMac Intel

Responder a kaly Cancelar respuesta

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.