Como usar extensiones no actualizadas en Firefox 1.0PR

Al instalar una extensión en Firefox, lo primero que hace la aplicación es comprobar en el archivo install.rdf cuales son las versiones mínimas (minVersion) y máximas (maxVersion) de la aplicación para las que se puede instalar la extensión. En el caso de que la versión actual no se encuentre en ese intervalo, Firefox no nos dejará instalarla o en el caso de que estemos actualizando Firefox a una versión posterior, la deshabilitará.

Esto puede ser bastante molesto si sabemos que la extensión funciona con la nueva versión de Firefox y que lo único que ocurre es que el creador no ha actualizado maxVersion en el install.rdf. Hasta ahora la única solución que conocía era editar la extensión y cambiar el valor de maxVersion, pero leyendo un comentario de Barrapunto acabo de descubrir que también podemos falsificar la versión del navegador, en lugar de tener que modificar cada una de las extensiones.

Solo tenemos que escribir about:config en la barra de dirección, buscar la clave app.extensions.version y cambiar el valor de 0.10 a 0.9. Con esto ya puedo volver a utilizar el notificador de Bloglines en Firefox 1.0PR 🙂

Comentarios
  1. y eso no intrfiere en proximas instalaciones de plugis y/o funcionamiento del navegador para otras cosas, como por ejemplo actualizaciones u otras cosas?

    Responder

  2. No sé como funcionará eso, pero hay otra clave en el registro ese de Firefox que dice: app.version

    Lo otro será la versión que se les pide a las extensiones. Vamos, digo yo 😉

    Responder

  3. Con el notificador de Bloglines me funciona, no así con la traducción al euskera de Firefox.

    Responder

  4. logico, la traducción es mucho mas compleja que una simple extensión y se han cambiado/añadido un montón de cadenas :uch: pero casi todas las extensiones deberían tirar en la 1.0PR si lo hacían en la 0.9.3
    Andérez, de todas formas la función de actualización ahora mismo o no funciona o no lo hace muy bien 🙁

    Responder

  5. Tambien acaba de salir el Qute 2.1.3 :OO
    Digo eso porque me parece el mejor tema para Firefox, ya que el que viene por defecto es más feo que pagarle a un padre. 😯

    Responder

  6. El Qute ese es como el de mi Firebird/0.7 😯

    Responder

  7. Tenemos esclavizados a 343 geeks trabajando 0.764 segundos al día para crear esta página.

    8O8O8O8O8O

    Responder

  8. es que qute es el nombre del que antes era el tema por defecto de firefox toad, el de ahora se llama winstripe

    Responder

  9. emmmm…. lo de los geeks son las estadisticas de la creacion de la página. el número de geeks es el número de consultas a la bbdd y el número de segundos esclavizados el tiempo que se tardó en generar a página
    es una mano de obra barata xD

    Responder

  10. Barata y eficiente… 0.539 segundos no está mal 😀

    Responder

  11. eso es porque les damos primas en forma de muñecos de gollum y camisetas de debian

    Responder

  12. Ya no hay que “hackear” Firefox, ha salido la version del notifier de Bloglines para la 1.0 PR

    http://www.bloglines.com/about/news#68

    Responder

  13. gracias por el dato erral 🙂

    Responder

  14. […] mayoría de las veces, para resolver el problema, basta modificar un valor en un archivo interno de la extensión que informa a Firefox sobre el mayor número de versión para el que está pensada la […]

    Responder

Deja un comentario