Deshabilitando DEP en Service Pack 2 de XP

Una de las razones de que algunos programas no funcionen bien al actualizar al nuevo Service Pack se debe a una nueva función llamada DEP (Data Execution Prevention o Prevención de Ejecución de Datos). Puede causar problemas como el que los codecs DivX no aparezcan en la lista de codecs disponibles y por lo tanto no se puedan reproducir videos comprimidos con ese codec o aparezcan otros problemas, como se menciona en este hilo de los foros de DivX.com.

La solución consiste en deshabilitar DEP, lo cual según Microsoft implica riesgos, pero ninguno que no existiera antes de instalar el SP2 ya que no estaba incluido en el SP1. Traduciendo el procedimiento descrito en la web de DivX.com:

  • Inicio -> Ejecutar
  • Escribimos Notepad %SYSTEMDRIVE%Boot.ini
  • Debajo de [operating systems] reemplazamos /NoExecute=xxxxx con /Execute
  • Guardarmos el archivo Boot.ini
  • Reiniciar el PC

IMPORTANTE: Haz una copia de seguridad de tu archivo Boot.ini file antes de realizar los cambios

Comentarios
  1. […] dows XP, que trae algunas novedades interesantes y de regalo, algunas incompatibilidades y problemas para algunos afortunados. En todo caso parece s […]

    Responder

  2. rubiotel

    😡 me he instalado el sevice pack 2 y demomento cuando uso el boton derecho del raton se bloqea todo y me sale un informe de errores de windons:drwtsn32.exe deve cerrarse.Se trata de un programa del sistems operativo llamado Dr wanson y no se como solucionar el problema.ayuda

    Responder

  3. xpero

    Pues a mi me da pedo cuendo conecto mi flash USB con partición protegida con contraseña. Es de la marca QDI, pero uno de Verbatim también da pedo (se reinicia el PC sin pantallazo azul ni previo aviso). Por ahora es lo único raro que le he encontrado. Muy apañado el comfigurador de redes inalámbricas integrado de Msoft.

    Responder

  4. Nestor

    yo instale el SP2 y he tenido varios problemas con mi xp pro entre ellos mi quemador no graba cds solo los lee el explorador se hizo mucho muy lento a pesar de tener DSL y es muy molesto estar viendo tantas advertencias de seguridad por cualquier cosa.

    Responder

  5. roberto

    instale el servive pack2 y comencé a tener problemas con mi conexión a internet. se conectaba e iba perdiendo velocidad hasta no encontrar el servidor. Como pueden servir actualizaciones defectuosas?

    Responder

  6. Fran

    A mi me pasa exactamente lo mismo.
    Tampoco sé la solución, puede que tengamos que dedicarnos a otra cosa.
    Si alguien te a dado la solución, agradeceria la compartieses con este inutil.
    Un saludo y gracias a quien pueda ayudarnos.

    Responder

  7. JAD

    Hola
    A mi me pasa lo mismo con el boton derecho del raton
    como arreglarlo?

    Responder

  8. Claudia

    No puedo abrir Inicio. Conclusión: No puedo desactivar el DEP. ¿Qué puedo hacer? Ayúdenme por favor.

    Responder

  9. Andre

    cuando escribo el archivo notepad %systemdrive%boot.ini dice que no lo encuentra

    Responder

Deja un comentario