ATI Catalyst 9.1 para Linux

Buenas noticias para los poseedores de tarjetas gráficas de ATI / AMD que usen Linux, y es que AMD ha publicado la versión 9.1 de sus drivers Catalyst, los cuales mejoran el soporte de Composite a la hora de reproducir vídeos (ya no tendremos esos molestos parpadeos en los vídeos al tener Compiz activado), añaden soporte para OpenGL 3.0 y Hybrid CrossFire (que reparte el trabajo entre nuestra gráfica integrada y una segunda gráfica que instalemos) y solucionan algún que otro bug.

Si queréis probar la nueva versión de los drivers podéis descargar el instalador desde la web de AMD: ATI Catalyst 9.1 Linux Driver (78.5MB).

30 pensamientos en “ATI Catalyst 9.1 para Linux”

  1. De lujo… precisamente ayer en la noche descargué la actualizacion del driver y mola perfectamente… y es que eso de tener que desabilitar todos los efectos del escritorio para poder ver videos era algo que no me hacia mucha gracia..

    Muchisimas gracias por el aporte!!!

  2. Yo estoy usando los drivers libres con KDE 4.2 y no tengo ningún problema ni con los videos y ni con el composite.

    Si no juegas, o tus juegos no son 3D de última generación, el driver libre es bastante más estable, al menos con mi 9600 así es, y el rendimiento es bueno.

  3. Yo todavia tengo problemas con mi tarjeta integrada hd 3200, :'(

    Mi tarjeta hace un ruido pero cuando le conecto otro monitor se arregla el problema :D, pero lo tengo que hacer cada que reinicio >=(

    Busque en los foros oficiales de amd/ati y este bug ya lleva rato pero no lo han podido arreglar, con esta version el ruido disminuyo pero no lo han podido quitar y menos en ubuntu 🙁

    Ademas la aceleracion 2D es deficiente si no lo configuro como 2 monitores >=@

  4. Tengo rato usando AMD, mucho antes de los 64 bits y toda la cosa, y esto no hace mas que confirmar que he acertado. Ojala y las demás compañías hagan sigan el ejemplo

  5. Pingback: Breves interesantes « Arcalinux

  6. Soluciona los parpadeos pero descompone otras cosas ¬¬ vaya de que forma más mala lo hace, ya no parpadea pero ahora totem, vlc, y todas las aplicaciones multimedia se dibujan mal e incompletas odio a ATI y su driver horrible en comparación del de NVIDIA que hasta puede correr juegos de windows con wine, todo gracias a lo pulido que esta su driver, si no intenten poner crysis, clive barjer’s jericho o cualquier juego reciente QUE SOPORTE WINE( esto es obvio pero lo pongo por si alguno me mal interpreta y cree que digo que por tener NVIDIA va a poder jugar en cualquier juego en GNU/Linux), con ATI es imposible, mientras que con NVIDIA funcionan a la primera. Definitibamente no les vuelvo a comprar una tarjeta en mi vida a estos que no se toman en serio a sus consumidores

  7. Edgar
    En mi compu una laptop con una radeon X1200 todos los juegos de Window que soporta wine corren perfectamente y todos los reproductores de video tambien, tambien corren perfectamente todos los juegos nativos de linux y ademas con este driver puedo ver peliculas de alta definicion por primera vez a pesar que mi maquina y mi tarjeta de video no fueron diseñadas para eso, en el Smplayer puedo abilitar ahora la opcion (ATI radeon AVIVO), lo cual permite reproducir videos usando al 100% el potencial de la tarjeta grafica ya que solo se reproduce por hardware, el driver de nvidia solo permite eso en Windows y nose si algun dia lo permitira en Linux.
    Obiamente tienes un problema en la configuracion de tu computadora, lo ideal seria formatear el disco e instalar linux desde cero.

  8. @Carlos

    Puede ser, pero aún así es imperdonable el tiempo que han tardado para hacer esto. Otro punto que acabo de notar es que los parpadeos persisten al usar aplicaciones que usen opengl como XBMC o googleearth 🙁

  9. Yo siempre he comprado ATI (nunca he tenido problemas en windows) pero ahora me he pasado a linux y vaya mierda.

    La próxima que me compre será una nVidia, ya que todo el mundo habla muy bien de su driver para linux.

    Edgar: Me pasa exactamente lo mismo que a tí con los videos. Que mierda!

  10. Pues yo no puedo instalarlo en ubuntu y se me va a low graphics mode. El caso es que en la versión 8.04 (instala el driver libre “ati”), el instalador de drivers propietarios de hardware me detectaba la tarjeta y el programa hacía su trabajo y bien (entre comillas, claro), pero si quieres instalar la ultima versión del driver (bajandolo de los servidores de ATI), el instalador rula perfectamente, pero luego no funciona y hay que volver a Low graphics.

    El caso es que con la 8.10 ni siquiera podía instalar el sistema por que no llegaba a ver el escritorio (se apagaba la pantalla, no se ponia negra, se apagaba).

    Probando con jaunty (la ultima alpha)conseguí instalar el sistema sin problemas (me las prometía muy felices), y la resolución del monitor era la correcta. Pero al tratar de instalar el propietario no me salia nada, y el driver que carga es el “vesa”, ni siquiera el “ati”. Instalé la ultima versión de la pagina de ATI sin problemas, pero al reiniciar me sale el maldito asistente de “low graphics”…. Yo no se si estos de Ubuntu cada vez hacen las cosas peor (con lo bien que iba el paquete displayconfig-gtk…)

    Maldito el dia en que me compre esta tarjeta….

    Ahhh, la tarjeta es una Sapphire HD2600 Pro AGP (creo que el problema es que es AGP, ya que en Windows tengo que instalar una versión “fix” de los drivers)

  11. Hey Edgar, tenía el mismo problema que vos, pero se soluciona agregando a la sección DEVICE de /etc/X11/xorg.conf la siguiente linea:

    Option “TexturedVideo” “off”

    Bueno ojalá leas este comentario y cuentes.

  12. @Carlos, yo tengo una placa integrada en PC de escritorio de la misma familia, una X1250. Con los drivers 9.1al tener activados los efectos de escritorio y reproducir un video con XV, el sistema se vuelve inestable. Al poner en pantalla completa el video, el sistema se cuelga completamente debiendo reiniciar.
    En mi caso, ATI de mal en peor…

  13. hola a todos, tengo instalado en mi hp compaq 6515b ubuntu 8.10 y tengo un problema con la tarjeta de video que no esta instalada y esta demasiado lenta. que puedo hacer? como puedo instalar los drivers de la ATI en mi sistema operativo?

  14. Rafa, esto lo puedes solucionar asi:

    Pulsas Alt F2 (abre una ventana “Ejecutar aplicación”)
    Escribes: “gstreamer-properties” (Sin las comillas, y apretamos ejecutar)

    Vas a la pestaña VIDEO>Salida Predeterminada>Complemento: X Window System
    (Sin XV) (seleccionamos esta opcion y apretamos Cerrar en el botón inferior)

    (estos pasos están para evitar que nuestros Driver ATI no hagan fallar la X y cierren la sección con solo tratar de reproducir un vídeo maximizado)

    un saludo.

  15. Hola, al bajar e instalar el controlador ATI radeon xpress 200 no me permite instalarlo y me manda el siguiente mensaje:

    Error: ./default_policy.sh does not support version
    default:v2:i686:lib::none:2.6.31-16-generic; make sure that the version is being
    correctly set by –iscurrentdistro

    Alguien podría ayudarme porfavor! Gracias!

  16. Hola, alguien podría ayudarme acabo de instalar a mi laptop toshiba satelite A215 AMD Turion 64×2, con acelerador grafico ATI RADEON X1200 y no puedo cambiar los electos visuales de ninguno a normal o extra. Bueno eso paso luego de instalarle el
    “ati-driver-istaller-10-2-x86.x86_64.run”.
    Para intalar el ati me pidio hacer esto en una terminal “sudo etc/init.d/gdm stop”.
    Como ago para colocar como estaba en principio?
    O que me suguieren?
    Gracias de antemano…

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.